Web App Unavailable

Incident Report for BoxHero

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 16:16 UTC

Monitoring

We suspected a DNS-related issue with our router and have deployed a new server.

While DNS propagation may take some time, we expect the issue to be resolved on the new server.
Posted Oct 20, 2025 - 16:02 UTC

Identified

We are currently investigating the issue causing the Web App to be inaccessible.

Our team is working to identify and resolve the problem as quickly as possible.
Posted Oct 20, 2025 - 15:08 UTC
This incident affected: BoxHero Web.